WordPress, update che aggiorna gli update – Punto Informatico



Roma – Arrivato a pochi giorni di distanza dalla versione precedente, WordPress 4.9.3 avrebbe dovuto costituire un aggiornamento di “manutenzione” senza particolari patemi con la correzione di decine di bug e vulnerabilità di sicurezza. Nella pratica, la nuova release ha provocato un guaio ancora peggiore di quelli che si incaricava di correggere.

WordPress 4.9.3 include infatti un bug che può portare al malfunzionamento degli aggiornamenti automatici del CMS, una caratteristica abilitata di default che però ora rischia di non funzionare come previsto. Un’ulteriore release (WordPress 4.9.4) è stata quindi rilasciata dal team di WordPress, ma a causa del bug di cui sopra va prevedibilmente installata manualmente dall’utente tramite l’apposito pulsante comparso sulla bacheca WP.

Il mezzo pasticcio degli ultimi aggiornamenti evidenzia la tendenza del progetto WordPress a scivolare sui bug – di sicurezza e non solo – anche se alcuni utenti hanno confermato di non aver avuto problemi nel passare automaticamente dalla release 4.9.3 all’ultima 4.9.4.

Quello che invece preoccupa ancora è la potenziale minaccia di CVE-2018-6389, una falla sfruttabile per condurre attacchi DDoS contro i siti WordPress e per cui non esiste ancora una correzione. Al momento gli sviluppatori di WP sostengono si tratti di un problema da gestire lato server, quindi di competenza dei servizi di hosting più che del CMS.

Un aggiornamento è arrivato infine anche per Jetpack, plug-in aggiuntivo che molti utenti WP considerano un’installazione obbligata e che con l’ultima versione (Jetpack 5.8) introduce una nuova modalità di ricerca, il caricamento “pigro” e ottimizzato delle immagini e altro ancora.

Alfonso Maruccia



Related Post